Debian-Sicherheitsankündigung

DSA-424-1 mc -- Pufferüberlauf

Datum des Berichts:
16. Jan 2004
Betroffene Pakete:
mc
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In der Bugtraq-Datenbank (bei SecurityFocus): BugTraq ID 8658.
In Mitres CVE-Verzeichnis: CVE-2003-1023.
Weitere Informationen:

Im Midnight Commander, einem Dateimanager, wurde eine Verwundbarkeit entdeckt, durch die eine manipulierte Archivdatei (wie z.B. eine .tar-Datei) die Ausführung beliebigen Codes verursachen kann, wenn sie durch Midnight Commander geöffnet wird.

Für die aktuelle stable Distribution (Woody) wurde dieses Problem in Version 4.5.55-1.2woody2 behoben.

Für die unstable Distribution (Sid) wurde dieses Problem in Version 1:4.6.0-4.6.1-pre1-1 behoben.

Wir empfehlen Ihnen, Ihr mc-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 3.0 (woody)

Quellcode:
http://security.debian.org/pool/updates/main/m/mc/mc_4.5.55-1.2woody2.dsc
http://security.debian.org/pool/updates/main/m/mc/mc_4.5.55-1.2woody2.diff.gz
http://security.debian.org/pool/updates/main/m/mc/mc_4.5.55.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/m/mc/gmc_4.5.55-1.2woody2_alpha.deb
http://security.debian.org/pool/updates/main/m/mc/mc_4.5.55-1.2woody2_alpha.deb
http://security.debian.org/pool/updates/main/m/mc/mc-common_4.5.55-1.2woody2_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/m/mc/gmc_4.5.55-1.2woody2_arm.deb
http://security.debian.org/pool/updates/main/m/mc/mc_4.5.55-1.2woody2_arm.deb
http://security.debian.org/pool/updates/main/m/mc/mc-common_4.5.55-1.2woody2_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/m/mc/gmc_4.5.55-1.2woody2_i386.deb
http://security.debian.org/pool/updates/main/m/mc/mc_4.5.55-1.2woody2_i386.deb
http://security.debian.org/pool/updates/main/m/mc/mc-common_4.5.55-1.2woody2_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/m/mc/gmc_4.5.55-1.2woody2_ia64.deb
http://security.debian.org/pool/updates/main/m/mc/mc_4.5.55-1.2woody2_ia64.deb
http://security.debian.org/pool/updates/main/m/mc/mc-common_4.5.55-1.2woody2_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/m/mc/gmc_4.5.55-1.2woody2_hppa.deb
http://security.debian.org/pool/updates/main/m/mc/mc_4.5.55-1.2woody2_hppa.deb
http://security.debian.org/pool/updates/main/m/mc/mc-common_4.5.55-1.2woody2_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/m/mc/gmc_4.5.55-1.2woody2_m68k.deb
http://security.debian.org/pool/updates/main/m/mc/mc_4.5.55-1.2woody2_m68k.deb
http://security.debian.org/pool/updates/main/m/mc/mc-common_4.5.55-1.2woody2_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/m/mc/gmc_4.5.55-1.2woody2_mips.deb
http://security.debian.org/pool/updates/main/m/mc/mc_4.5.55-1.2woody2_mips.deb
http://security.debian.org/pool/updates/main/m/mc/mc-common_4.5.55-1.2woody2_mips.deb
PowerPC:
http://security.debian.org/pool/updates/main/m/mc/gmc_4.5.55-1.2woody2_powerpc.deb
http://security.debian.org/pool/updates/main/m/mc/mc_4.5.55-1.2woody2_powerpc.deb
http://security.debian.org/pool/updates/main/m/mc/mc-common_4.5.55-1.2woody2_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/m/mc/gmc_4.5.55-1.2woody2_s390.deb
http://security.debian.org/pool/updates/main/m/mc/mc_4.5.55-1.2woody2_s390.deb
http://security.debian.org/pool/updates/main/m/mc/mc-common_4.5.55-1.2woody2_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/m/mc/gmc_4.5.55-1.2woody2_sparc.deb
http://security.debian.org/pool/updates/main/m/mc/mc_4.5.55-1.2woody2_sparc.deb
http://security.debian.org/pool/updates/main/m/mc/mc-common_4.5.55-1.2woody2_sparc.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.