Debian Security Advisory

DSA-426-1 netpbm-free -- insecure temporary files

Date Reported:
18 Jan 2004
Affected Packages:
Security database references:
In the Bugtraq database (at SecurityFocus): BugTraq ID 9442.
In Mitre's CVE dictionary: CVE-2003-0924.
CERT's vulnerabilities, advisories and incident notes: VU#487102.
More information:

netpbm is a graphics conversion toolkit made up of a large number of single-purpose programs. Many of these programs were found to create temporary files in an insecure manner, which could allow a local attacker to overwrite files with the privileges of the user invoking a vulnerable netpbm tool.

For the current stable distribution (woody) these problems have been fixed in version 2:9.20-8.4.

For the unstable distribution (sid) these problems have been fixed in version 2:9.25-9.

We recommend that you update your netpbm-free package.

Fixed in:

Debian GNU/Linux 3.0 (woody)

Intel IA-32:
Intel IA-64:
Motorola 680x0:
Big endian MIPS:
Little endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.