Debian Security Advisory

DSA-428-1 slocate -- buffer overflow

Date Reported:
20 Jan 2004
Affected Packages:
Security database references:
In the Bugtraq database (at SecurityFocus): BugTraq ID 8780.
In Mitre's CVE dictionary: CVE-2003-0848.
CERT's vulnerabilities, advisories and incident notes: VU#441956.
More information:

A vulnerability was discovered in slocate, a program to index and search for files, whereby a specially crafted database could overflow a heap-based buffer. This vulnerability could be exploited by a local attacker to gain the privileges of the "slocate" group, which can access the global database containing a list of pathnames of all files on the system, including those which should only be visible to privileged users.

This problem, and a category of potential similar problems, have been fixed by modifying slocate to drop privileges before reading a user-supplied database.

For the current stable distribution (woody) this problem has been fixed in version 2.6-1.3.2.

For the unstable distribution (sid) this problem will be fixed soon. Refer to Debian bug #226103 for status information.

We recommend that you update your slocate package.

Fixed in:

Debian GNU/Linux 3.0 (woody)

Intel IA-32:
Intel IA-64:
Motorola 680x0:
Big endian MIPS:
Little endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.