Debian Security Advisory

DSA-449-1 metamail -- buffer overflow, format string bugs

Date Reported:
24 Feb 2004
Affected Packages:
Security database references:
In the Bugtraq database (at SecurityFocus): BugTraq ID 9692.
In Mitre's CVE dictionary: CVE-2004-0104, CVE-2004-0105.
CERT's vulnerabilities, advisories and incident notes: VU#518518, VU#513062.
More information:

Ulf Härnhammar discovered two format string bugs (CAN-2004-0104) and two buffer overflow bugs (CAN-2004-0105) in metamail, an implementation of MIME. An attacker could create a carefully-crafted mail message which will execute arbitrary code as the victim when it is opened and parsed through metamail.

We have been devoting some effort to trying to avoid shipping metamail in the future. It became unmaintainable and these are probably not the last of the vulnerabilities.

For the stable distribution (woody) these problems have been fixed in version 2.7-45woody.2.

For the unstable distribution (sid) these problems will be fixed in version 2.7-45.2.

We recommend that you upgrade your metamail package.

Fixed in:

Debian GNU/Linux 3.0 (woody)

Intel IA-32:
Intel IA-64:
Motorola 680x0:
Big endian MIPS:
Little endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.