Aviso de seguridad de Debian

DSA-471-1 interchange -- olvido en saneamiento de entrada

Fecha del informe:
2 de abr de 2004
Paquetes afectados:
interchange
Vulnerable:
Referencias a bases de datos de seguridad:
En la base de datos de Bugtraq (en SecurityFocus): Id. en BugTraq 10005.
En el diccionario CVE de Mitre: CVE-2004-0374.
Información adicional:

Recientemente se descubrió una vulnerabilidad en Interchange, un sistema general HTTP de comercio electrónico y visualización de bases de datos. Esta vulnerabilidad la puede aprovechar un atacante para exponer la información de la aplicación Interchange y usar esta información para leer y manipular datos sensibles.

Para la distribución estable (woody), este problema se ha corregido en la versión 4.8.3.20020306-1.woody.2.

Para la distribución inestable (sid), este problema se ha corregido en la versión 5.0.1-1.

Le recomendamos que actualice el paquete interchange.

Arreglado en:

Debian GNU/Linux 3.0 (woody)

Fuentes:
http://security.debian.org/pool/updates/main/i/interchange/interchange_4.8.3.20020306-1.woody.2.dsc
http://security.debian.org/pool/updates/main/i/interchange/interchange_4.8.3.20020306-1.woody.2.diff.gz
http://security.debian.org/pool/updates/main/i/interchange/interchange_4.8.3.20020306.orig.tar.gz
Componentes independientes de la arquitectura:
http://security.debian.org/pool/updates/main/i/interchange/interchange-cat-foundation_4.8.3.20020306-1.woody.2_all.deb
http://security.debian.org/pool/updates/main/i/interchange/interchange-ui_4.8.3.20020306-1.woody.2_all.deb
Alpha:
http://security.debian.org/pool/updates/main/i/interchange/interchange_4.8.3.20020306-1.woody.2_alpha.deb
http://security.debian.org/pool/updates/main/i/interchange/libapache-mod-interchange_4.8.3.20020306-1.woody.2_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/i/interchange/interchange_4.8.3.20020306-1.woody.2_arm.deb
http://security.debian.org/pool/updates/main/i/interchange/libapache-mod-interchange_4.8.3.20020306-1.woody.2_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/i/interchange/interchange_4.8.3.20020306-1.woody.2_i386.deb
http://security.debian.org/pool/updates/main/i/interchange/libapache-mod-interchange_4.8.3.20020306-1.woody.2_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/i/interchange/interchange_4.8.3.20020306-1.woody.2_ia64.deb
http://security.debian.org/pool/updates/main/i/interchange/libapache-mod-interchange_4.8.3.20020306-1.woody.2_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/i/interchange/interchange_4.8.3.20020306-1.woody.2_hppa.deb
http://security.debian.org/pool/updates/main/i/interchange/libapache-mod-interchange_4.8.3.20020306-1.woody.2_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/i/interchange/interchange_4.8.3.20020306-1.woody.2_m68k.deb
http://security.debian.org/pool/updates/main/i/interchange/libapache-mod-interchange_4.8.3.20020306-1.woody.2_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/i/interchange/interchange_4.8.3.20020306-1.woody.2_mips.deb
http://security.debian.org/pool/updates/main/i/interchange/libapache-mod-interchange_4.8.3.20020306-1.woody.2_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/i/interchange/interchange_4.8.3.20020306-1.woody.2_mipsel.deb
http://security.debian.org/pool/updates/main/i/interchange/libapache-mod-interchange_4.8.3.20020306-1.woody.2_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/i/interchange/interchange_4.8.3.20020306-1.woody.2_powerpc.deb
http://security.debian.org/pool/updates/main/i/interchange/libapache-mod-interchange_4.8.3.20020306-1.woody.2_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/i/interchange/interchange_4.8.3.20020306-1.woody.2_s390.deb
http://security.debian.org/pool/updates/main/i/interchange/libapache-mod-interchange_4.8.3.20020306-1.woody.2_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/i/interchange/interchange_4.8.3.20020306-1.woody.2_sparc.deb
http://security.debian.org/pool/updates/main/i/interchange/libapache-mod-interchange_4.8.3.20020306-1.woody.2_sparc.deb

Las sumas MD5 de los ficheros que se listan están disponibles en el aviso original.