Debian Security Advisory

DSA-472-1 fte -- several vulnerabilities

Date Reported:
03 Apr 2004
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 203871.
In the Bugtraq database (at SecurityFocus): BugTraq ID 10041.
In Mitre's CVE dictionary: CVE-2003-0648.
CERT's vulnerabilities, advisories and incident notes: VU#900964, VU#354838.
More information:

Steve Kemp and Jaguar discovered a number of buffer overflow vulnerabilities in vfte, a version of the fte editor which runs on the Linux console, found in the package fte-console. This program is setuid root in order to perform certain types of low-level operations on the console.

Due to these bugs, setuid privilege has been removed from vfte, making it only usable by root. We recommend using the terminal version (in the fte-terminal package) instead, which runs on any capable terminal including the Linux console.

For the stable distribution (woody) these problems have been fixed in version 0.49.13-15woody1.

For the unstable distribution (sid) these problems have been fixed in version 0.50.0-1.1.

We recommend that you update your fte package.

Fixed in:

Debian GNU/Linux 3.0 (woody)

Intel IA-32:
Intel IA-64:
Motorola 680x0:
Big endian MIPS:
Little endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.