Debian-Sicherheitsankündigung

DSA-480-1 linux-kernel-2.4.17+2.4.18-hppa -- Mehrere Verwundbarkeiten

Datum des Berichts:
14. Apr 2004
Betroffene Pakete:
kernel-image-2.4.17-hppa kernel-image-2.4.18-hppa
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In der Bugtraq-Datenbank (bei SecurityFocus): BugTraq ID 10152.
In Mitres CVE-Verzeichnis: CVE-2004-0003, CVE-2004-0010, CVE-2004-0109, CVE-2004-0177, CVE-2004-0178.
Weitere Informationen:

Mehrere schwerwiegende Probleme wurden im Linux-Kernel entdeckt. Diese Aktualisierung ist für Linux 2.4.17 und 2.4.18 für die hppa- (PA-RISC) -Architektur. Das Common Vulnerabilities and Exposures-Projekt identifiziert die folgenden Probleme, die mit dieser Aktualisierung behoben werden:

  • CAN-2004-0003

    Eine Verwundbarkeit wurde im R128 DRI-Treiber im Linux-Kernel entdeckt, was es möglicherweise einem Angreifer erlaubt, nicht autorisierte Privilegien zu erlangen. Alan Cox und Thomas Biege entwickelten eine Korrektur dafür.

  • CAN-2004-0010

    Arjan van de Ven entdeckte einen Stack-basierten Pufferüberlauf in der ncp_lookup Funktion für ncpfs im Linux-Kernel, was es einem Angreifer erlauben könnte, nicht autorisierte Privilegien zu erlangen. Petr Vandrovec entwickelte eine Korrektur dafür.

  • CAN-2004-0109

    zen-parse entdeckte eine Pufferüberlauf-Verwundbarkeit in der ISO9660-Dateisystem-Komponente des Linux-Kernels, was von einem Angreifer missbraucht werden könnte, um nicht autorisierte root-Rechte zu erlangen. Sebastian Krahmer und Ernie Petrides entwickelten eine Korrektur dafür.

  • CAN-2004-0177

    Solar Designer entdeckte ein Informationsleck im ext3-Code von Linux. Im schlimmsten Fall kann ein Angreifer sensible Daten wie kryptographische Schlüssel lesen, was andernfalls niemals auf den Datenträger geschrieben würde. Theodore Ts'o entwickelte eine Korrektur dafür.

  • CAN-2004-0178

    Andreas Kies entdeckte ein Denial of Service im Sound Blaster-Treiber in Linux. Er entwickelte auch eine Korrektur dafür.

Diese Probleme wurden auch Upstream in Linux 2.4.26 beseitigt und werden in Linux 2.6.6 beseitigt werden.

Für die stable Distribution (Woody) wurden diese Probleme in Version 32.4 für Linux 2.4.17 und in Version 62.3 für Linux 2.4.18 behoben.

Für die unstable Distribution (Sid) werden diese Probleme bald behoben werden.

Wir empfehlen Ihnen, Ihre Kernel-Pakete unverzüglich zu aktualisieren, entweder mit einem von Debian bereitgestellten Kernel oder mit einem selbstkompilierten.

Verwundbarkeitsmatrix für CAN-2004-0109.

Behoben in:

Debian GNU/Linux 3.0 (woody)

Quellcode:
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.17-hppa/kernel-image-2.4.17-hppa_32.4.dsc
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.17-hppa/kernel-image-2.4.17-hppa_32.4.tar.gz
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.18-hppa/kernel-image-2.4.18-hppa_62.3.dsc
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.18-hppa/kernel-image-2.4.18-hppa_62.3.tar.gz
Architektur-unabhängige Dateien:
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.17-hppa/kernel-source-2.4.17-hppa_32.4_all.deb
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.18-hppa/kernel-source-2.4.18-hppa_62.3_all.deb
HPPA:
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.17-hppa/kernel-headers-2.4.17-hppa_32.4_hppa.deb
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.17-hppa/kernel-image-2.4.17-32_32.4_hppa.deb
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.17-hppa/kernel-image-2.4.17-32-smp_32.4_hppa.deb
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.17-hppa/kernel-image-2.4.17-64_32.4_hppa.deb
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.17-hppa/kernel-image-2.4.17-64-smp_32.4_hppa.deb
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.18-hppa/kernel-headers-2.4.18-hppa_62.3_hppa.deb
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.18-hppa/kernel-image-2.4.18-32_62.3_hppa.deb
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.18-hppa/kernel-image-2.4.18-32-smp_62.3_hppa.deb
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.18-hppa/kernel-image-2.4.18-64_62.3_hppa.deb
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.18-hppa/kernel-image-2.4.18-64-smp_62.3_hppa.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.