Рекомендация Debian по безопасности

DSA-480-1 linux-kernel-2.4.17+2.4.18-hppa -- различные уязвимости

Дата сообщения:
14.04.2004
Затронутые пакеты:
kernel-image-2.4.17-hppa kernel-image-2.4.18-hppa
Уязвим:
Да
Ссылки на базы данных по безопасности:
В базе данных Bugtraq (на SecurityFocus): Идентификатор BugTraq 10152.
В каталоге Mitre CVE: CVE-2004-0003, CVE-2004-0010, CVE-2004-0109, CVE-2004-0177, CVE-2004-0178.
Более подробная информация:

Недавно обнаружены несколько серьёзных ошибок в ядре Linux. Это обновление касается ядра Linux версий 2.4.17 и 2.4.18 для архитектуры hppa (PA-RISC). Проект Common Vulnerabilities and Exposures (CVE) идентифицировал следующие проблемы, исправленные в этом обновлении:

  • CAN-2004-0003

    Обнаружена уязвимость в драйвере R128 DRI ядра Linux, которая может позволить нападающему присвоить чужие привилегии. Алан Кокс (Alan Cox) и Томас Биге (Thomas Biege) исправили эту ошибку.

  • CAN-2004-0010

    Аржан ван де Вен (Arjan van de Ven) обнаружил возможность переполнения буфера стека при работе функции ncp_lookup драйвера файловой системы ncpfs ядра Linux, что может позволить нападающему присвоить чужие привилегии. Пётр Вандровек (Petr Vandrovec) исправил эту ошибку.

  • CAN-2004-0109

    zen-parse обнаружил возможность переполнения буфера в драйвере файловой системы ISO9660 ядра Linux, что может быть использовано нападающим для присвоения привилегий суперпользователя. Себастьян Крамер (Sebastian Krahmer) и Эрни Петридес (Ernie Petrides) исправили эту ошибку.

  • CAN-2004-0177

    Solar Designer обнаружил возможность утечки информации в драйвере файловой системы ext3 ядра Linux. В худшем случае нападающий может прочесть такие важные данные, как ключи шифрования и электронной подписи. Теодоре Тсо (Theodore Ts'o) исправил эту ошибку.

  • CAN-2004-0178

    Андреас Киес (Andreas Kies) обнаружил возможность отказа в обслуживании в драйвере звуковой карты Sound Blaster ядра Linux. Он же исправил эту ошибку.

Эти проблемы исправлены в исходном коде ядра Linux версии 2.4.26 и будут исправлены в Linux версии 2.6.6.

В стабильном дистрибутиве (woody) эти проблемы исправлены в ядре Linux 2.4.17 версии 32.4, ядре Linux 2.4.18 версии 62.3.

В нестабильном дистрибутиве (sid) эти проблемы будут исправлены в ближайшее время.

Мы рекомендуем вам немедленно обновить пакеты ядра, заменив их поставляемыми с Debian либо скомпилированными самостоятельно.

Таблица уязвимости CAN-2004-0109

Исправлено в:

Debian GNU/Linux 3.0 (woody)

Исходный код:
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.17-hppa/kernel-image-2.4.17-hppa_32.4.dsc
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.17-hppa/kernel-image-2.4.17-hppa_32.4.tar.gz
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.18-hppa/kernel-image-2.4.18-hppa_62.3.dsc
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.18-hppa/kernel-image-2.4.18-hppa_62.3.tar.gz
Независимые от архитектуры компоненты:
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.17-hppa/kernel-source-2.4.17-hppa_32.4_all.deb
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.18-hppa/kernel-source-2.4.18-hppa_62.3_all.deb
HPPA:
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.17-hppa/kernel-headers-2.4.17-hppa_32.4_hppa.deb
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.17-hppa/kernel-image-2.4.17-32_32.4_hppa.deb
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.17-hppa/kernel-image-2.4.17-32-smp_32.4_hppa.deb
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.17-hppa/kernel-image-2.4.17-64_32.4_hppa.deb
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.17-hppa/kernel-image-2.4.17-64-smp_32.4_hppa.deb
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.18-hppa/kernel-headers-2.4.18-hppa_62.3_hppa.deb
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.18-hppa/kernel-image-2.4.18-32_62.3_hppa.deb
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.18-hppa/kernel-image-2.4.18-32-smp_62.3_hppa.deb
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.18-hppa/kernel-image-2.4.18-64_62.3_hppa.deb
http://security.debian.org/pool/updates/main/k/kernel-image-2.4.18-hppa/kernel-image-2.4.18-64-smp_62.3_hppa.deb

Контрольные суммы MD5 этих файлов доступны в исходном сообщении.