Debian-Sicherheitsankündigung

DSA-491-1 linux-kernel-2.4.19-mips -- Mehrere Verwundbarkeiten

Datum des Berichts:
17. Apr 2004
Betroffene Pakete:
kernel-source-2.4.19 kernel-patch-2.4.19-mips
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In der Bugtraq-Datenbank (bei SecurityFocus): BugTraq ID 10141, BugTraq ID 10152, BugTraq ID 9570, BugTraq ID 9691, BugTraq ID 9985, BugTraq ID 10152.
In Mitres CVE-Verzeichnis: CVE-2004-0003, CVE-2004-0010, CVE-2004-0109, CVE-2004-0177, CVE-2004-0178.
Weitere Informationen:

Mehrere schwerwiegende Probleme wurden im Linux-Kernel entdeckt. Diese Aktualisierung ist für Linux 2.4.19 für die MIPS-Architektur. Das »Common Vulnerabilities and Exposures«-Projekt stellt die folgenden Probleme fest, die mit dieser Aktualisierung behoben werden:

  • CAN-2004-0003

    Eine Verwundbarkeit wurde im R128 DRI-Treiber im Linux-Kernel entdeckt, was es möglicherweise einem Angreifer erlaubt, nicht autorisierte Privilegien zu erlangen. Alan Cox und Thomas Biege entwickelten eine Korrektur dafür.

  • CAN-2004-0010

    Arjan van de Ven entdeckte einen Stack-basierten Pufferüberlauf in der ncp_lookup Funktion für ncpfs im Linux-Kernel, was es einem Angreifer erlauben könnte, nicht autorisierte Privilegien zu erlangen. Petr Vandrovec entwickelte eine Korrektur dafür.

  • CAN-2004-0109

    zen-parse entdeckte eine Pufferüberlauf-Verwundbarkeit in der ISO9660-Dateisystem-Komponente des Linux-Kernels, was von einem Angreifer missbraucht werden könnte, um nicht autorisierte root-Rechte zu erlangen. Sebastian Krahmer und Ernie Petrides entwickelten eine Korrektur dafür.

  • CAN-2004-0177

    Solar Designer entdeckte ein Informationsleck im ext3-Code von Linux. Im schlimmsten Fall kann ein Angreifer sensible Daten wie kryptographische Schlüssel lesen, was andernfalls niemals auf den Datenträger geschrieben würde. Theodore Ts'o entwickelte eine Korrektur dafür.

  • CAN-2004-0178

    Andreas Kies entdeckte ein Denial of Service im Sound Blaster-Treiber in Linux. Er entwickelte auch eine Korrektur dafür.

Diese Probleme wurden auch Upstream in Linux 2.4.26 beseitigt und werden in Linux 2.6.6 beseitigt werden.

Die folgende Sicherheitsmatrix erklärt, welche Kernel-Versionen für welche Architekturen bereits korrigiert wurden und welche stattdessen entfernt werden.

Architektur stable (Woody) unstable (Sid) in Sid entfernt
Quelle 2.4.19-4.woody2 2.4.25-3 2.4.19-11
mips 2.4.19-0.020911.1.woody4 2.4.25-0.040415.1 2.4.19-0.020911.8

Wir empfehlen Ihnen, Ihre Kernel-Pakete unverzüglich zu aktualisieren, entweder mit einem von Debian bereitgestellten Kernel oder mit einem selbstkompilierten.

Verwundbarkeitsmatrix für CAN-2004-0109.

Behoben in:

Debian GNU/Linux 3.0 (woody)

Quellcode:
http://security.debian.org/pool/updates/main/k/kernel-source-2.4.19/kernel-source-2.4.19_2.4.19-4.woody2.dsc
http://security.debian.org/pool/updates/main/k/kernel-source-2.4.19/kernel-source-2.4.19_2.4.19-4.woody2.diff.gz
http://security.debian.org/pool/updates/main/k/kernel-source-2.4.19/kernel-source-2.4.19_2.4.19.orig.tar.gz
http://security.debian.org/pool/updates/main/k/kernel-patch-2.4.19-mips/kernel-patch-2.4.19-mips_2.4.19-0.020911.1.woody4.dsc
http://security.debian.org/pool/updates/main/k/kernel-patch-2.4.19-mips/kernel-patch-2.4.19-mips_2.4.19-0.020911.1.woody4.tar.gz
Architektur-unabhängige Dateien:
http://security.debian.org/pool/updates/main/k/kernel-source-2.4.19/kernel-doc-2.4.19_2.4.19-4.woody2_all.deb
http://security.debian.org/pool/updates/main/k/kernel-source-2.4.19/kernel-source-2.4.19_2.4.19-4.woody2_all.deb
http://security.debian.org/pool/updates/main/k/kernel-patch-2.4.19-mips/kernel-patch-2.4.19-mips_2.4.19-0.020911.1.woody4_all.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/k/kernel-patch-2.4.19-mips/kernel-headers-2.4.19_2.4.19-0.020911.1.woody4_mips.deb
http://security.debian.org/pool/updates/main/k/kernel-patch-2.4.19-mips/kernel-image-2.4.19-r4k-ip22_2.4.19-0.020911.1.woody4_mips.deb
http://security.debian.org/pool/updates/main/k/kernel-patch-2.4.19-mips/kernel-image-2.4.19-r5k-ip22_2.4.19-0.020911.1.woody4_mips.deb
http://security.debian.org/pool/updates/main/k/kernel-patch-2.4.19-mips/mips-tools_2.4.19-0.020911.1.woody4_mips.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.