Bulletin d'alerte Debian

DSA-524-1 rlpr -- Plusieurs failles

Date du rapport :
19 juin 2004
Paquets concernés :
rlpr
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans la base de données de suivi des bogues (chez SecurityFocus) : Identifiant BugTraq 10578.
Dans le dictionnaire CVE du Mitre : CVE-2004-0393, CVE-2004-0454.
Plus de précisions :

jaguar@felinemenace.org a découvert une faille de sécurité basée sur le format des chaînes de caractères dans rlpr, un utilitaire pour l'impression avec lpd qui n'utilise pas /etc/printcap. En examinant cette faille de sécurité, on a également découvert un dépassement de tampon dans le code incriminé. En exploitant l'une de ces failles, un attaquant local ou distant peut éventuellement faire exécuter un code arbitraire avec les privilèges 1) du processus rlpd (à distance), ou 2) du superutilisateur (local).

CAN-2004-0393 : faille de sécurité basée sur le format des chaînes de caractères via syslog(3) dans la fonction msg() dans rlpr

CAN-2004-0454 : dépassement de tampon dans la fonction msg() dans rlpr

Pour l'actuelle distribution stable (Woody), ce problème a été corrigé dans la version 2.02-7woody1.

Pour la distribution instable (Sid), ce problème sera bientôt corrigé.

Nous vous recommandons de mettre à jour votre paquet rlpr.

Corrigé dans :

Debian GNU/Linux 3.0 (woody)

Source :
http://security.debian.org/pool/updates/main/r/rlpr/rlpr_2.02-7woody1.dsc
http://security.debian.org/pool/updates/main/r/rlpr/rlpr_2.02-7woody1.diff.gz
http://security.debian.org/pool/updates/main/r/rlpr/rlpr_2.02.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/r/rlpr/rlpr_2.02-7woody1_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/r/rlpr/rlpr_2.02-7woody1_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/r/rlpr/rlpr_2.02-7woody1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/r/rlpr/rlpr_2.02-7woody1_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/r/rlpr/rlpr_2.02-7woody1_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/r/rlpr/rlpr_2.02-7woody1_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/r/rlpr/rlpr_2.02-7woody1_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/r/rlpr/rlpr_2.02-7woody1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/r/rlpr/rlpr_2.02-7woody1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/r/rlpr/rlpr_2.02-7woody1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/r/rlpr/rlpr_2.02-7woody1_sparc.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.