Aviso de seguridad de Debian

DSA-529-1 netkit-telnet-ssl -- cadena de formato

Fecha del informe:
17 de jul de 2004
Paquetes afectados:
netkit-telnet-ssl
Vulnerable:
Referencias a bases de datos de seguridad:
En el diccionario CVE de Mitre: CVE-2004-0640.
Información adicional:

«b0f» descubrió una vulnerabilidad de cadena de formato en netkit-telnet-ssl, que potencialmente podía permitir que un atacante remoto provocara la ejecución de código arbitrario con los privilegios del demonio telnet (de forma predefinida, el usuario «telnetd»).

Para la distribución estable actual (woody), este problema se ha corregido en la versión 0.17.17+0.1-2woody1.

Para la distribución inestable (sid), este problema se ha corregido en la versión 0.17.24+0.1-2.

Le recomendamos que actualice el paquete netkit-telnet-ssl.

Arreglado en:

Debian GNU/Linux 3.0 (woody)

Fuentes:
http://security.debian.org/pool/updates/main/n/netkit-telnet-ssl/netkit-telnet-ssl_0.17.17+0.1-2woody1.dsc
http://security.debian.org/pool/updates/main/n/netkit-telnet-ssl/netkit-telnet-ssl_0.17.17+0.1-2woody1.diff.gz
http://security.debian.org/pool/updates/main/n/netkit-telnet-ssl/netkit-telnet-ssl_0.17.17+0.1.orig.tar.gz
ARM:
http://security.debian.org/pool/updates/main/n/netkit-telnet-ssl/telnet-ssl_0.17.17+0.1-2woody1_arm.deb
http://security.debian.org/pool/updates/main/n/netkit-telnet-ssl/telnetd-ssl_0.17.17+0.1-2woody1_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/n/netkit-telnet-ssl/telnet-ssl_0.17.17+0.1-2woody1_i386.deb
http://security.debian.org/pool/updates/main/n/netkit-telnet-ssl/telnetd-ssl_0.17.17+0.1-2woody1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/n/netkit-telnet-ssl/telnet-ssl_0.17.17+0.1-2woody1_ia64.deb
http://security.debian.org/pool/updates/main/n/netkit-telnet-ssl/telnetd-ssl_0.17.17+0.1-2woody1_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/n/netkit-telnet-ssl/telnet-ssl_0.17.17+0.1-2woody1_hppa.deb
http://security.debian.org/pool/updates/main/n/netkit-telnet-ssl/telnetd-ssl_0.17.17+0.1-2woody1_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/n/netkit-telnet-ssl/telnet-ssl_0.17.17+0.1-2woody1_m68k.deb
http://security.debian.org/pool/updates/main/n/netkit-telnet-ssl/telnetd-ssl_0.17.17+0.1-2woody1_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/n/netkit-telnet-ssl/telnet-ssl_0.17.17+0.1-2woody1_mips.deb
http://security.debian.org/pool/updates/main/n/netkit-telnet-ssl/telnetd-ssl_0.17.17+0.1-2woody1_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/n/netkit-telnet-ssl/telnet-ssl_0.17.17+0.1-2woody1_mipsel.deb
http://security.debian.org/pool/updates/main/n/netkit-telnet-ssl/telnetd-ssl_0.17.17+0.1-2woody1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/n/netkit-telnet-ssl/telnet-ssl_0.17.17+0.1-2woody1_powerpc.deb
http://security.debian.org/pool/updates/main/n/netkit-telnet-ssl/telnetd-ssl_0.17.17+0.1-2woody1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/n/netkit-telnet-ssl/telnet-ssl_0.17.17+0.1-2woody1_s390.deb
http://security.debian.org/pool/updates/main/n/netkit-telnet-ssl/telnetd-ssl_0.17.17+0.1-2woody1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/n/netkit-telnet-ssl/telnet-ssl_0.17.17+0.1-2woody1_sparc.deb
http://security.debian.org/pool/updates/main/n/netkit-telnet-ssl/telnetd-ssl_0.17.17+0.1-2woody1_sparc.deb

Las sumas MD5 de los ficheros que se listan están disponibles en el aviso original.