Debian Security Advisory

DSA-533-1 courier -- cross-site scripting

Date Reported:
22 Jul 2004
Affected Packages:
Security database references:
In the Bugtraq database (at SecurityFocus): BugTraq ID 10588.
In Mitre's CVE dictionary: CVE-2004-0591.
More information:

A cross-site scripting vulnerability was discovered in sqwebmail, a web mail application provided by the courier mail suite, whereby an attacker could cause web script to be executed within the security context of the sqwebmail application by injecting it via an email message.

For the current stable distribution (woody), this problem has been fixed in version 0.37.3-2.5.

For the unstable distribution (sid), this problem has been fixed in version 0.45.4-4.

We recommend that you update your courier package.

Fixed in:

Debian GNU/Linux 3.0 (woody)

Architecture-independent component:
Intel IA-32:
Intel IA-64:
Motorola 680x0:
Big endian MIPS:
Little endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.