Debian Security Advisory

DSA-535-1 squirrelmail -- several vulnerabilities

Date Reported:
02 Aug 2004
Affected Packages:
Security database references:
In the Bugtraq database (at SecurityFocus): BugTraq ID 10246, BugTraq ID 10439.
In Mitre's CVE dictionary: CVE-2004-0519, CVE-2004-0520, CVE-2004-0521, CVE-2004-0639.
More information:

Four vulnerabilities were discovered in squirrelmail:

  • CAN-2004-0519

    Multiple cross-site scripting (XSS) vulnerabilities in SquirrelMail 1.4.2 allow remote attackers to execute arbitrary script as other users and possibly steal authentication information via multiple attack vectors, including the mailbox parameter in compose.php.

  • CAN-2004-0520

    Cross-site scripting (XSS) vulnerability in mime.php for SquirrelMail before 1.4.3 allows remote attackers to insert arbitrary HTML and script via the content-type mail header, as demonstrated using read_body.php.

  • CAN-2004-0521

    SQL injection vulnerability in SquirrelMail before 1.4.3 RC1 allows remote attackers to execute unauthorized SQL statements, with unknown impact, probably via abook_database.php.

  • CAN-2004-0639

    Multiple cross-site scripting (XSS) vulnerabilities in Squirrelmail 1.2.10 and earlier allow remote attackers to inject arbitrary HTML or script via (1) the $mailer variable in read_body.php, (2) the $senderNames_part variable in mailbox_display.php, and possibly other vectors including (3) the $event_title variable or (4) the $event_text variable.

For the current stable distribution (woody), these problems have been fixed in version 1:1.2.6-1.4.

For the unstable distribution (sid), these problems have been fixed in 2:1.4.3a-0.1 and earlier versions.

We recommend that you update your squirrelmail package.

Fixed in:

Debian GNU/Linux 3.0 (woody)

Architecture-independent component:

MD5 checksums of the listed files are available in the original advisory.