Debian Security Advisory

DSA-537-1 ruby -- insecure file permissions

Date Reported:
16 Aug 2004
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 260779.
In Mitre's CVE dictionary: CVE-2004-0755.
More information:

Andres Salomon noticed a problem in the CGI session management of Ruby, an object-oriented scripting language. CGI::Session's FileStore (and presumably PStore, but not in Debian woody) implementations store session information insecurely. They simply create files, ignoring permission issues. This can lead an attacker who has also shell access to the webserver to take over a session.

For the stable distribution (woody) this problem has been fixed in version 1.6.7-3woody3.

For the unstable and testing distributions (sid and sarge) this problem has been fixed in version 1.8.1+1.8.2pre1-4.

We recommend that you upgrade your libruby package.

Fixed in:

Debian GNU/Linux 3.0 (woody)

Architecture-independent component:
Intel IA-32:
Intel IA-64:
Motorola 680x0:
Big endian MIPS:
Little endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.