Debian Security Advisory

DSA-546-1 gdk-pixbuf -- several vulnerabilities

Date Reported:
16 Sep 2004
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2004-0753, CVE-2004-0782, CVE-2004-0788.
CERT's vulnerabilities, advisories and incident notes: VU#825374, VU#729894, VU#577654.
More information:

Chris Evans discovered several problems in gdk-pixbuf, the GdkPixBuf library used in Gtk. It is possible for an attacker to execute arbitrary code on the victims machine. Gdk-pixbuf for Gtk+1.2 is an external package. For Gtk+2.0 it's part of the main gtk package.

The Common Vulnerabilities and Exposures Project identifies the following vulnerabilities:

For the stable distribution (woody) these problems have been fixed in version 0.17.0-2woody2.

For the unstable distribution (sid) these problems have been fixed in version 0.22.0-7.

We recommend that you upgrade your gdk-pixbuf packages.

Fixed in:

Debian GNU/Linux 3.0 (woody)

Intel IA-32:
Intel IA-64:
Motorola 680x0:
Big endian MIPS:
Little endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.