Debian Security Advisory

DSA-566-1 cupsys -- unsanitised input

Date Reported:
14 Oct 2004
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2004-0923.
CERT's vulnerabilities, advisories and incident notes: VU#557062.
More information:

An information leak has been detected in CUPS, the Common UNIX Printing System, which may lead to the disclosure of sensitive information, such as user names and passwords which are written into log files.

The used patch only eliminates the authentication information in the device URI which is logged in the error_log file. It does not eliminate the URI from the environment and process table, which is why the CUPS developers recommend that system administrators do not code authentication information in device URIs in the first place.

For the stable distribution (woody) this problem has been fixed in version 1.1.14-5woody7.

For the unstable distribution (sid) this problem has been fixed in version 1.1.20final+rc1-9.

We recommend that you upgrade your CUPS package.

Fixed in:

Debian GNU/Linux 3.0 (woody)

Intel IA-32:
Intel IA-64:
Motorola 680x0:
Big endian MIPS:
Little endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.