Bulletin d'alerte Debian

DSA-578-1 mpg123 -- Dépassement de tampon

Date du rapport :
1er novembre 2004
Paquets concernés :
mpg123
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2004-0982.
Plus de précisions :

Carlos Barros a découvert un dépassement de tampon dans la routine d'authentification HTTP de mpg123, un lecteur audio populaire (mais non libre) des formats MPEG couche 1/2/3. Si un utilisateur lit une liste d'écoute ou une URL malveillante, un attaquant pourrait exécuter n'importe quel code avec les droits de l'utilisateur.

Pour la distribution stable (Woody), ce problème a été corrigé dans la version 0.59r-13woody4.

Pour la distribution instable (Sid), ce problème a été corrigé dans la version 0.59r-17.

Nous vous recommandons de mettre à jour votre paquet mpg123.

Corrigé dans :

Debian GNU/Linux 3.0 (woody)

Source :
http://security.debian.org/pool/updates/non-free/m/mpg123/mpg123_0.59r-13woody4.dsc
http://security.debian.org/pool/updates/non-free/m/mpg123/mpg123_0.59r-13woody4.diff.gz
http://security.debian.org/pool/updates/non-free/m/mpg123/mpg123_0.59r.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/non-free/m/mpg123/mpg123_0.59r-13woody4_alpha.deb
http://security.debian.org/pool/updates/non-free/m/mpg123/mpg123-esd_0.59r-13woody4_alpha.deb
ARM:
http://security.debian.org/pool/updates/non-free/m/mpg123/mpg123_0.59r-13woody4_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/non-free/m/mpg123/mpg123_0.59r-13woody4_i386.deb
http://security.debian.org/pool/updates/non-free/m/mpg123/mpg123-esd_0.59r-13woody4_i386.deb
http://security.debian.org/pool/updates/non-free/m/mpg123/mpg123-nas_0.59r-13woody4_i386.deb
http://security.debian.org/pool/updates/non-free/m/mpg123/mpg123-oss-3dnow_0.59r-13woody4_i386.deb
http://security.debian.org/pool/updates/non-free/m/mpg123/mpg123-oss-i486_0.59r-13woody4_i386.deb
HPPA:
http://security.debian.org/pool/updates/non-free/m/mpg123/mpg123_0.59r-13woody4_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/non-free/m/mpg123/mpg123_0.59r-13woody4_m68k.deb
PowerPC:
http://security.debian.org/pool/updates/non-free/m/mpg123/mpg123_0.59r-13woody4_powerpc.deb
http://security.debian.org/pool/updates/non-free/m/mpg123/mpg123-esd_0.59r-13woody4_powerpc.deb
Sun Sparc:
http://security.debian.org/pool/updates/non-free/m/mpg123/mpg123_0.59r-13woody4_sparc.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.