Debian Security Advisory

DSA-582-1 libxml -- buffer overflow

Date Reported:
02 Nov 2004
Affected Packages:
libxml, libxml2
Security database references:
In Mitre's CVE dictionary: CVE-2004-0989.
More information:

"infamous41md" discovered several buffer overflows in libxml and libxml2, the XML C parser and toolkits for GNOME. Missing boundary checks could cause several buffers to be overflown, which may cause the client to execute arbitrary code.

The following vulnerability matrix lists corrected versions of these libraries:

For the stable distribution (woody) these problems have been fixed in version 1.8.17-2woody2 of libxml and in version 2.4.19-4woody2 of libxml2.

For the unstable distribution (sid) these problems have been fixed in version 1.8.17-9 of libxml and in version 2.6.11-5 of libxml2.

These problems have also been fixed in version 2.6.15-1 of libxml2 in the experimental distribution.

We recommend that you upgrade your libxml packages.

Fixed in:

Debian GNU/Linux 3.0 (woody)

Intel IA-32:
Intel IA-64:
Motorola 680x0:
Big endian MIPS:
Little endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.