Debian-Sicherheitsankündigung

DSA-610-1 cscope -- Unsichere temporäre Datei

Datum des Berichts:
17. Dez 2004
Betroffene Pakete:
cscope
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In der Debian-Fehlerdatenbank: Fehler 282815.
In der Bugtraq-Datenbank (bei SecurityFocus): BugTraq ID 11697.
In Mitres CVE-Verzeichnis: CVE-2004-0996.
Weitere Informationen:

In cscope, einem Programm zur interaktiven Untersuchung von C-Quelltext, wurde eine Verwundbarkeit entdeckt, die lokalen Benutzern erlaubt, Dateien mittels eines Symlink-Angriffs zu überschreiben.

Für die Stable-Distribution (Woody) wurde dieses Problem in Version 15.3-1woody2 behoben.

Für die Unstable-Distribution (Sid) wurde dieses Problem in Version 15.5-1 behoben.

Wir empfehlen Ihnen, Ihr cscope-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 3.0 (woody)

Quellcode:
http://security.debian.org/pool/updates/main/c/cscope/cscope_15.3-1woody2.dsc
http://security.debian.org/pool/updates/main/c/cscope/cscope_15.3-1woody2.diff.gz
http://security.debian.org/pool/updates/main/c/cscope/cscope_15.3.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/c/cscope/cscope_15.3-1woody2_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/c/cscope/cscope_15.3-1woody2_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/c/cscope/cscope_15.3-1woody2_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/c/cscope/cscope_15.3-1woody2_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/c/cscope/cscope_15.3-1woody2_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/c/cscope/cscope_15.3-1woody2_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/c/cscope/cscope_15.3-1woody2_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/c/cscope/cscope_15.3-1woody2_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/c/cscope/cscope_15.3-1woody2_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/c/cscope/cscope_15.3-1woody2_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/c/cscope/cscope_15.3-1woody2_sparc.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.