Debian Security Advisory

DSA-615-1 debmake -- insecure temporary files

Date Reported:
22 Dec 2004
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 286382.
In Mitre's CVE dictionary: CVE-2004-1179.
More information:

Javier Fernández-Sanguino Peña from the Debian Security Audit Project noticed that the debstd script from debmake, a deprecated helper package for Debian packaging, created temporary directories in an insecure manner. This can be exploited by a malicious user to overwrite arbitrary files owned by the victim.

For the stable distribution (woody) this problem has been fixed in version 3.6.10.woody.1.

For the unstable distribution (sid) this problem has been fixed in version 3.7.7.

We recommend that you upgrade your debmake package.

Fixed in:

Debian GNU/Linux 3.0 (woody)

Architecture-independent component:

MD5 checksums of the listed files are available in the original advisory.