Bulletin d'alerte Debian

DSA-615-1 debmake -- Fichier temporaire non sécurisé

Date du rapport :
22 décembre 2004
Paquets concernés :
debmake
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 286382.
Dans le dictionnaire CVE du Mitre : CVE-2004-1179.
Plus de précisions :

Javier Fernández-Sanguino Peña du projet d'audit de sécurité de Debian a remarqué que le script debstd du paquet debmake, paquet obsolète d'aide à la construction de paquets Debian, créait des répertoires temporaires d'une manière non sécurisée. Cette faille peut être exploitée par un utilisateur malveillant dans le but d'écraser de manière arbitraire des fichiers appartenant à la victime.

Pour l'actuelle distribution stable (Woody), ce problème a été corrigé dans la version 3.6.10.woody.1.

Pour la distribution instable (Sid), ce problème a été corrigé dans la version version 3.7.7.

Nous vous recommandons de mettre à jour votre paquet debmake.

Corrigé dans :

Debian GNU/Linux 3.0 (woody)

Source :
http://security.debian.org/pool/updates/main/d/debmake/debmake_3.6.10.woody.1.dsc
http://security.debian.org/pool/updates/main/d/debmake/debmake_3.6.10.woody.1.tar.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/d/debmake/debmake_3.6.10.woody.1_all.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.