Säkerhetsbulletin från Debian

DSA-642-1 gallery -- flera sårbarheter

Rapporterat den:
2005-01-17
Berörda paket:
gallery
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Bugtraq-databasen (hos SecurityFocus): BugTraq-id 11602.
I Mitres CVE-förteckning: CVE-2004-1106.
Ytterligare information:

Flera sårbarheter har upptäckts i gallery, ett webbaserat fotoalbum skrivet i PHP4. Projektet Common Vulnerabilities and Exposures identifierar följande sårbarheter:

  • CAN-2004-1106

    Jim Paris upptäckte en serveröverskridande skriptsårbarhet som gör det möjligt att sätta in kod genom att använda specialskrivna URL:er.

  • CVE-NOMATCH

    Gallerys uppströmsutvecklare har rättat flera fall av möjlig variabelinjicering som kunde lura gallery att utföra oönskade funktioner, t.ex läcka databaslösenord.

För den stabila utgåvan (Woody) har dessa problem rättats i version 1.2.5-8woody3.

För den instabila utgåvan (Sid) har dessa problem rättats i version 1.4.4-pl4-1.

Vi rekommenderar att ni uppgraderar ert gallery-paket.

Rättat i:

Debian GNU/Linux 3.0 (woody)

Källkod:
http://security.debian.org/pool/updates/main/g/gallery/gallery_1.2.5-8woody3.dsc
http://security.debian.org/pool/updates/main/g/gallery/gallery_1.2.5-8woody3.diff.gz
http://security.debian.org/pool/updates/main/g/gallery/gallery_1.2.5.orig.tar.gz
Arkitekturoberoende komponent:
http://security.debian.org/pool/updates/main/g/gallery/gallery_1.2.5-8woody3_all.deb

MD5-kontrollsummor för dessa filer finns i originalbulletinen.