Debian Security Advisory

DSA-644-1 chbg -- buffer overflow

Date Reported:
18 Jan 2005
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 285904.
In Mitre's CVE dictionary: CVE-2004-1264.
More information:

Danny Lungstrom discovered a vulnerability in chbg, a tool to change background pictures. A maliciously crafted configuration/scenario file could overflow a buffer and lead to the execution of arbitrary code on the victim's machine.

For the stable distribution (woody) this problem has been fixed in version 1.5-1woody1.

For the unstable distribution (sid) this problem has been fixed in version 1.5-4.

We recommend that you upgrade your chbg package.

Fixed in:

Debian GNU/Linux 3.0 (woody)

Intel IA-32:
Intel IA-64:
HPPA: Cannot be updated due to compiler error.
Motorola 680x0:
Big endian MIPS:
Little endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.