Debians sikkerhedsbulletin

DSA-644-1 chbg -- bufferoverløb

Rapporteret den:
18. jan 2005
Berørte pakker:
chbg
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 285904.
I Mitres CVE-ordbog: CVE-2004-1264.
Yderligere oplysninger:

Danny Lungstrom har opdaget en sårbarhed i chbg, et værktøj til at ændre baggrundsbilleder med. En ondsindet fremstillet configuration/scenario-fil kunne få en buffer til at løbe over og gøre det muligt at udføre vilkårlig kode på offerets maskine.

I den stabile distribution (woody) er dette problem rettet i version 1.5-1woody1.

I den ustabile distribution (sid) er dette problem rettet i version 1.5-4.

Vi anbefaler at du opgraderer din chbg-pakke.

Rettet i:

Debian GNU/Linux 3.0 (woody)

Kildekode:
http://security.debian.org/pool/updates/main/c/chbg/chbg_1.5-1woody1.dsc
http://security.debian.org/pool/updates/main/c/chbg/chbg_1.5-1woody1.diff.gz
http://security.debian.org/pool/updates/main/c/chbg/chbg_1.5.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/c/chbg/chbg_1.5-1woody1_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/c/chbg/chbg_1.5-1woody1_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/c/chbg/chbg_1.5-1woody1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/c/chbg/chbg_1.5-1woody1_ia64.deb
HPPA: Cannot be updated due to compiler error.
Motorola 680x0:
http://security.debian.org/pool/updates/main/c/chbg/chbg_1.5-1woody1_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/c/chbg/chbg_1.5-1woody1_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/c/chbg/chbg_1.5-1woody1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/c/chbg/chbg_1.5-1woody1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/c/chbg/chbg_1.5-1woody1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/c/chbg/chbg_1.5-1woody1_sparc.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.