Debian-Sicherheitsankündigung

DSA-649-1 xtrlock -- Pufferüberlauf

Datum des Berichts:
20. Jan 2005
Betroffene Pakete:
xtrlock
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In der Debian-Fehlerdatenbank: Fehler 278190, Fehler 278191.
In Mitres CVE-Verzeichnis: CVE-2005-0079.
Weitere Informationen:

Ein Pufferüberlauf wurde in xtrlock, einem kleinen Programm, das die X-Anzeige sperrt, entdeckt. Dies kann von einem böswilligen lokalen Angreifer ausgenutzt werden, um das Sperrprogramm zum Absturz zu bringen und die Desktopsitzung zu übernehmen.

Für die Stable-Distribution (Woody) wurde dieses Problem in Version 2.0-6woody2 behoben.

Für die Unstable-Distribution (Sid) wurde dieses Problem in Version 2.0-9 behoben.

Wir empfehlen Ihnen, Ihr xtrlock-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 3.0 (woody)

Quellcode:
http://security.debian.org/pool/updates/main/x/xtrlock/xtrlock_2.0-6woody2.dsc
http://security.debian.org/pool/updates/main/x/xtrlock/xtrlock_2.0-6woody2.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/x/xtrlock/xtrlock_2.0-6woody2_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/x/xtrlock/xtrlock_2.0-6woody2_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/x/xtrlock/xtrlock_2.0-6woody2_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/x/xtrlock/xtrlock_2.0-6woody2_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/x/xtrlock/xtrlock_2.0-6woody2_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/x/xtrlock/xtrlock_2.0-6woody2_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/x/xtrlock/xtrlock_2.0-6woody2_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/x/xtrlock/xtrlock_2.0-6woody2_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/x/xtrlock/xtrlock_2.0-6woody2_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/x/xtrlock/xtrlock_2.0-6woody2_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/x/xtrlock/xtrlock_2.0-6woody2_sparc.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.