Bulletin d'alerte Debian

DSA-650-1 sword -- Manque de vérification des entrées

Date du rapport :
20 janvier 2005
Paquets concernés :
sword
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2005-0015.
Plus de précisions :

Ulf Härnhammar a découvert qu'en raison d'un manque de vérification des entrées dans diatheke, un script CGI pour la réalisation et le parcours d'un site web sur la bible, il est possible d'exécuter des commandes arbitraires grâce à un lien spécialement créé.

Pour l'actuelle distribution stable (Woody), ce problème a été corrigé dans la version 1.5.3-3woody2.

Pour la distribution instable (Sid), ce problème sera bientôt corrigé.

Nous vous recommandons de mettre à jour votre paquet diatheke.

Corrigé dans :

Debian GNU/Linux 3.0 (woody)

Source :
http://security.debian.org/pool/updates/main/s/sword/sword_1.5.3-3woody2.dsc
http://security.debian.org/pool/updates/main/s/sword/sword_1.5.3-3woody2.diff.gz
http://security.debian.org/pool/updates/main/s/sword/sword_1.5.3.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/s/sword/diatheke_1.5.3-3woody2_alpha.deb
http://security.debian.org/pool/updates/main/s/sword/libsword-dev_1.5.3-3woody2_alpha.deb
http://security.debian.org/pool/updates/main/s/sword/libsword-runtime_1.5.3-3woody2_alpha.deb
http://security.debian.org/pool/updates/main/s/sword/libsword1_1.5.3-3woody2_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/s/sword/diatheke_1.5.3-3woody2_arm.deb
http://security.debian.org/pool/updates/main/s/sword/libsword-dev_1.5.3-3woody2_arm.deb
http://security.debian.org/pool/updates/main/s/sword/libsword-runtime_1.5.3-3woody2_arm.deb
http://security.debian.org/pool/updates/main/s/sword/libsword1_1.5.3-3woody2_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/s/sword/diatheke_1.5.3-3woody2_i386.deb
http://security.debian.org/pool/updates/main/s/sword/libsword-dev_1.5.3-3woody2_i386.deb
http://security.debian.org/pool/updates/main/s/sword/libsword-runtime_1.5.3-3woody2_i386.deb
http://security.debian.org/pool/updates/main/s/sword/libsword1_1.5.3-3woody2_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/s/sword/diatheke_1.5.3-3woody2_ia64.deb
http://security.debian.org/pool/updates/main/s/sword/libsword-dev_1.5.3-3woody2_ia64.deb
http://security.debian.org/pool/updates/main/s/sword/libsword-runtime_1.5.3-3woody2_ia64.deb
http://security.debian.org/pool/updates/main/s/sword/libsword1_1.5.3-3woody2_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/s/sword/diatheke_1.5.3-3woody2_hppa.deb
http://security.debian.org/pool/updates/main/s/sword/libsword-dev_1.5.3-3woody2_hppa.deb
http://security.debian.org/pool/updates/main/s/sword/libsword-runtime_1.5.3-3woody2_hppa.deb
http://security.debian.org/pool/updates/main/s/sword/libsword1_1.5.3-3woody2_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/s/sword/diatheke_1.5.3-3woody2_m68k.deb
http://security.debian.org/pool/updates/main/s/sword/libsword-dev_1.5.3-3woody2_m68k.deb
http://security.debian.org/pool/updates/main/s/sword/libsword-runtime_1.5.3-3woody2_m68k.deb
http://security.debian.org/pool/updates/main/s/sword/libsword1_1.5.3-3woody2_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/s/sword/diatheke_1.5.3-3woody2_mips.deb
http://security.debian.org/pool/updates/main/s/sword/libsword-dev_1.5.3-3woody2_mips.deb
http://security.debian.org/pool/updates/main/s/sword/libsword-runtime_1.5.3-3woody2_mips.deb
http://security.debian.org/pool/updates/main/s/sword/libsword1_1.5.3-3woody2_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/s/sword/diatheke_1.5.3-3woody2_mipsel.deb
http://security.debian.org/pool/updates/main/s/sword/libsword-dev_1.5.3-3woody2_mipsel.deb
http://security.debian.org/pool/updates/main/s/sword/libsword-runtime_1.5.3-3woody2_mipsel.deb
http://security.debian.org/pool/updates/main/s/sword/libsword1_1.5.3-3woody2_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/s/sword/diatheke_1.5.3-3woody2_powerpc.deb
http://security.debian.org/pool/updates/main/s/sword/libsword-dev_1.5.3-3woody2_powerpc.deb
http://security.debian.org/pool/updates/main/s/sword/libsword-runtime_1.5.3-3woody2_powerpc.deb
http://security.debian.org/pool/updates/main/s/sword/libsword1_1.5.3-3woody2_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/s/sword/diatheke_1.5.3-3woody2_s390.deb
http://security.debian.org/pool/updates/main/s/sword/libsword-dev_1.5.3-3woody2_s390.deb
http://security.debian.org/pool/updates/main/s/sword/libsword-runtime_1.5.3-3woody2_s390.deb
http://security.debian.org/pool/updates/main/s/sword/libsword1_1.5.3-3woody2_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/s/sword/diatheke_1.5.3-3woody2_sparc.deb
http://security.debian.org/pool/updates/main/s/sword/libsword-dev_1.5.3-3woody2_sparc.deb
http://security.debian.org/pool/updates/main/s/sword/libsword-runtime_1.5.3-3woody2_sparc.deb
http://security.debian.org/pool/updates/main/s/sword/libsword1_1.5.3-3woody2_sparc.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.