Bulletin d'alerte Debian

DSA-654-1 enscript -- Plusieurs failles de sécurité

Date du rapport :
21 janvier 2005
Paquets concernés :
enscript
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2004-1184, CVE-2004-1185, CVE-2004-1186.
Plus de précisions :

Erik Sjölund a découvert plusieurs problèmes de sécurité dans enscript, un programme pour convertir un texte ASCII en Postscript et d'autres formats. Le projet Common Vulnerabilities and Exposures a identifié les failles de sécurité suivantes :

  • CAN-2004-1184

    Une entrée non vérifiée peut permettre l'exécution de n'importe quelle commande via la fonctionnalité de communication par EPSF. Ceci a été désactivé dans cette version ainsi que dans la version originale.

  • CAN-2004-1185

    Dû à un manque de vérifications sur les noms de fichiers, il est possible qu'un nom de fichier spécialement conçu puisse exécuter n'importe quelle commande.

  • CAN-2004-1186

    Plusieurs dépassements de tampon peuvent faire planter le programme.

Normalement, enscript est utilisé seulement localement, mais étant donné qu'il est aussi exécuté au sein de viewcvs, certains problèmes ci-dessus peuvent facilement être exploités à distance.

Pour l'actuelle distribution stable (Woody), ces problèmes ont été corrigés dans la version 1.6.3-1.3.

Pour la distribution instable (Sid), ces problèmes ont été corrigés dans la version 1.6.4-6.

Nous vous recommandons de mettre à jour votre paquet enscript.

Corrigé dans :

Debian GNU/Linux 3.0 (woody)

Source :
http://security.debian.org/pool/updates/main/e/enscript/enscript_1.6.3-1.3.dsc
http://security.debian.org/pool/updates/main/e/enscript/enscript_1.6.3-1.3.diff.gz
http://security.debian.org/pool/updates/main/e/enscript/enscript_1.6.3.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/e/enscript/enscript_1.6.3-1.3_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/e/enscript/enscript_1.6.3-1.3_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/e/enscript/enscript_1.6.3-1.3_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/e/enscript/enscript_1.6.3-1.3_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/e/enscript/enscript_1.6.3-1.3_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/e/enscript/enscript_1.6.3-1.3_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/e/enscript/enscript_1.6.3-1.3_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/e/enscript/enscript_1.6.3-1.3_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/e/enscript/enscript_1.6.3-1.3_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/e/enscript/enscript_1.6.3-1.3_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/e/enscript/enscript_1.6.3-1.3_sparc.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.