Debian Security Advisory

DSA-669-1 php3 -- several vulnerabilities

Date Reported:
07 Feb 2005
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2004-0594, CVE-2004-0595.
More information:

Two vulnerabilities have been discovered in php4 which also apply to the version of php3 in the stable Debian distribution. The Common Vulnerabilities and Exposures project identifies the following problems:

  • CAN-2004-0594

    The memory_limit functionality allows remote attackers to execute arbitrary code under certain circumstances.

  • CAN-2004-0595

    The strip_tags function does not filter null (\0) characters within tag names when restricting input to allowed tags, which allows dangerous tags to be processed by some web browsers which could lead to cross-site scripting (XSS) vulnerabilities.

For the stable distribution (woody) these problems have been fixed in version 3.0.18-23.1woody2.

For the unstable distribution (sid) these problems have been fixed in version 3.0.18-27.

We recommend that you upgrade your php3 packages.

Fixed in:

Debian GNU/Linux 3.0 (woody)

Architecture-independent component:
Intel IA-32:
Intel IA-64:
Motorola 680x0:
Big endian MIPS:
Little endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.