Debian-Sicherheitsankündigung

DSA-675-1 hztty -- Privilegien-Erweiterung

Datum des Berichts:
10. Feb 2005
Betroffene Pakete:
hztty
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In Mitres CVE-Verzeichnis: CVE-2005-0019.
Weitere Informationen:

Erik Sjölund entdeckte, dass hztty, ein Umwandlungsprogramm für die chinesischen Kodierungen GB, Big5 und zW/HZ in einer tty-Sitzung, dazu verwendet werden kann, beliebige Befehle mit den Rechten der Gruppe »utmp« auszuführen.

Für die Stable-Distribution (Woody) wurde dieses Problem in Version 2.0-5.2woody2 behoben.

Für die Unstable-Distribution (Sid) wurde dieses Problem in Version 2.0-6.1 behoben.

Wir empfehlen Ihnen, Ihr hztty-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 3.0 (woody)

Quellcode:
http://security.debian.org/pool/updates/main/h/hztty/hztty_2.0-5.2woody2.dsc
http://security.debian.org/pool/updates/main/h/hztty/hztty_2.0-5.2woody2.diff.gz
http://security.debian.org/pool/updates/main/h/hztty/hztty_2.0.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/h/hztty/hztty_2.0-5.2woody2_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/h/hztty/hztty_2.0-5.2woody2_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/h/hztty/hztty_2.0-5.2woody2_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/h/hztty/hztty_2.0-5.2woody2_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/h/hztty/hztty_2.0-5.2woody2_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/h/hztty/hztty_2.0-5.2woody2_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/h/hztty/hztty_2.0-5.2woody2_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/h/hztty/hztty_2.0-5.2woody2_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/h/hztty/hztty_2.0-5.2woody2_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/h/hztty/hztty_2.0-5.2woody2_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/h/hztty/hztty_2.0-5.2woody2_sparc.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.