Aviso de seguridad de Debian

DSA-681-1 synaesthesia -- escalada de privilegios

Fecha del informe:
14 de feb de 2005
Paquetes afectados:
synaesthesia
Vulnerable:
Referencias a bases de datos de seguridad:
En el diccionario CVE de Mitre: CVE-2005-0070.
Información adicional:

Erik Sjölund y Devin Carraway descubrieron que synaesthesia, un programa para representar sonidos visualmente, accedía a archivos de configuración y del mezclador controlados por el usuario con privilegios elevados. Por tanto, era posible leer archivos arbitrarios.

Para la distribución estable (woody), este problema se ha corregido en la versión 2.1-2.1woody3.

Para las distribuciones en pruebas (sarge) e inestable (sid), este problema no existe, porque synaesthesia ya no se instala con setuid root.

Le recomendamos que actualice el paquete synaesthesia.

Arreglado en:

Debian GNU/Linux 3.0 (woody)

Fuentes:
http://security.debian.org/pool/updates/main/s/synaesthesia/synaesthesia_2.1-2.1woody3.dsc
http://security.debian.org/pool/updates/main/s/synaesthesia/synaesthesia_2.1-2.1woody3.diff.gz
http://security.debian.org/pool/updates/main/s/synaesthesia/synaesthesia_2.1.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/s/synaesthesia/synaesthesia_2.1-2.1woody3_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/s/synaesthesia/synaesthesia_2.1-2.1woody3_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/s/synaesthesia/synaesthesia_2.1-2.1woody3_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/s/synaesthesia/synaesthesia_2.1-2.1woody3_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/s/synaesthesia/synaesthesia_2.1-2.1woody3_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/s/synaesthesia/synaesthesia_2.1-2.1woody3_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/s/synaesthesia/synaesthesia_2.1-2.1woody3_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/s/synaesthesia/synaesthesia_2.1-2.1woody3_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/s/synaesthesia/synaesthesia_2.1-2.1woody3_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/s/synaesthesia/synaesthesia_2.1-2.1woody3_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/s/synaesthesia/synaesthesia_2.1-2.1woody3_sparc.deb

Las sumas MD5 de los ficheros que se listan están disponibles en el aviso original.