Debian-Sicherheitsankündigung

DSA-682-1 awstats -- Fehlende Entschärfung der Eingabe

Datum des Berichts:
15. Feb 2005
Betroffene Pakete:
awstats
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In der Debian-Fehlerdatenbank: Fehler 294488.
In Mitres CVE-Verzeichnis: CVE-2005-0363.
Weitere Informationen:

Zusätzlich zu CAN-2005-0116 wurden weitere Verwundbarkeiten in awstats gefunden, einem mächtigen und vielfältigen Analyseprogramm von Webserver-Logdateien mit einer CGI-Oberfläche. Durch die fehlende Entschärfung von Eingaben können beliebige Befehle ausgeführt werden.

Für die Stable-Distribution (Woody) wurde dieses Problem in Version 4.0-0.woody.2 behoben.

Für die Unstable-Distribution (Sid) wurde dieses Problem in Version 6.2-1.2 behoben.

Wir empfehlen Ihnen, Ihr awstats-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 3.0 (woody)

Quellcode:
http://security.debian.org/pool/updates/main/a/awstats/awstats_4.0-0.woody.2.dsc
http://security.debian.org/pool/updates/main/a/awstats/awstats_4.0-0.woody.2.diff.gz
http://security.debian.org/pool/updates/main/a/awstats/awstats_4.0.orig.tar.gz
Architektur-unabhängige Dateien:
http://security.debian.org/pool/updates/main/a/awstats/awstats_4.0-0.woody.2_all.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.