Bulletin d'alerte Debian

DSA-682-1 awstats -- Entrée non vérifiée

Date du rapport :
15 février 2005
Paquets concernés :
awstats
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 294488.
Dans le dictionnaire CVE du Mitre : CVE-2005-0363.
Plus de précisions :

En complément de l'entrée CAN-2005-0116, encore d'autres vulnérabilités ont été découvertes dans awstats, un puissant et complet analyseur de journaux de serveur web, avec une interface CGI. L'absence de vérification d'une entrée permettait à des commandes arbitraires d'être exécutées.

Pour l'actuelle distribution stable (Woody), ce problème a été corrigé dans la version 4.0-0.woody.2.

Pour la distribution instable (Sid), ce problème a été corrigé dans la version 6.2-1.2.

Nous vous recommandons de mettre à jour votre paquet awstats.

Corrigé dans :

Debian GNU/Linux 3.0 (woody)

Source :
http://security.debian.org/pool/updates/main/a/awstats/awstats_4.0-0.woody.2.dsc
http://security.debian.org/pool/updates/main/a/awstats/awstats_4.0-0.woody.2.diff.gz
http://security.debian.org/pool/updates/main/a/awstats/awstats_4.0.orig.tar.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/a/awstats/awstats_4.0-0.woody.2_all.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.