Debian セキュリティ勧告

DSA-685-1 emacs21 -- フォーマット文字列脆弱性

報告日時:
2005-02-17
影響を受けるパッケージ:
emacs21
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2005-0100.
詳細:

Max Vozeler さんは、良く知られているエディタ Emacs の movemail ユーティリティに複数のフォーマット文字列脆弱性を発見しました。悪意を持った POP サーバへ接続させることで、攻撃者は mail グループの権限で任意のコードを実行させることが可能です。

安定版ディストリビューション (stable、コードネーム woody) では、これらの問題はバージョン 21.2-1woody3 で修正されています。

不安定版ディストリビューション (unstable、コードネーム sid) では、これらの問題はバージョン 21.3+1-9 で修正されています。

emacs パッケージのアップグレードをお勧めします。

修正:

Debian GNU/Linux 3.0 (woody)

ソース:
http://security.debian.org/pool/updates/main/e/emacs21/emacs21_21.2-1woody3.dsc
http://security.debian.org/pool/updates/main/e/emacs21/emacs21_21.2-1woody3.diff.gz
http://security.debian.org/pool/updates/main/e/emacs21/emacs21_21.2.orig.tar.gz
アーキテクチャ非依存コンポーネント:
http://security.debian.org/pool/updates/main/e/emacs21/emacs21-el_21.2-1woody3_all.deb
Alpha:
http://security.debian.org/pool/updates/main/e/emacs21/emacs21_21.2-1woody3_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/e/emacs21/emacs21_21.2-1woody3_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/e/emacs21/emacs21_21.2-1woody3_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/e/emacs21/emacs21_21.2-1woody3_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/e/emacs21/emacs21_21.2-1woody3_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/e/emacs21/emacs21_21.2-1woody3_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/e/emacs21/emacs21_21.2-1woody3_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/e/emacs21/emacs21_21.2-1woody3_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/e/emacs21/emacs21_21.2-1woody3_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/e/emacs21/emacs21_21.2-1woody3_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/e/emacs21/emacs21_21.2-1woody3_sparc.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。