Debian セキュリティ勧告

DSA-688-1 squid -- 入力に対するサニタイジングの欠落

報告日時:
2005-02-23
影響を受けるパッケージ:
squid
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2005-0446.
詳細:

squid 開発元のデベロッパーらは、squid に複数の問題を発見しました。squid は、 インターネットオブジェクトをキャッシュする、ポピュラーな WWW プロキシキャッシュプログラムです。攻撃者は、ある特定の DNS 応答によってリモートから squid をクラッシュさせられます。

安定版ディストリビューション (stable、コードネーム woody) では、これらの問題はバージョン 2.4.6-2woody7 で修正されています。

不安定版ディストリビューション (unstable、コードネーム sid) では、これらの問題はバージョン 2.5.8-3 で修正されています。

squid パッケージのアップグレードをお勧めします。

修正:

Debian GNU/Linux 3.0 (woody)

ソース:
http://security.debian.org/pool/updates/main/s/squid/squid_2.4.6-2woody7.dsc
http://security.debian.org/pool/updates/main/s/squid/squid_2.4.6-2woody7.diff.gz
http://security.debian.org/pool/updates/main/s/squid/squid_2.4.6.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/s/squid/squid_2.4.6-2woody7_alpha.deb
http://security.debian.org/pool/updates/main/s/squid/squid-cgi_2.4.6-2woody7_alpha.deb
http://security.debian.org/pool/updates/main/s/squid/squidclient_2.4.6-2woody7_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/s/squid/squid_2.4.6-2woody7_arm.deb
http://security.debian.org/pool/updates/main/s/squid/squid-cgi_2.4.6-2woody7_arm.deb
http://security.debian.org/pool/updates/main/s/squid/squidclient_2.4.6-2woody7_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/s/squid/squid_2.4.6-2woody7_i386.deb
http://security.debian.org/pool/updates/main/s/squid/squid-cgi_2.4.6-2woody7_i386.deb
http://security.debian.org/pool/updates/main/s/squid/squidclient_2.4.6-2woody7_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/s/squid/squid_2.4.6-2woody7_ia64.deb
http://security.debian.org/pool/updates/main/s/squid/squid-cgi_2.4.6-2woody7_ia64.deb
http://security.debian.org/pool/updates/main/s/squid/squidclient_2.4.6-2woody7_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/s/squid/squid_2.4.6-2woody7_hppa.deb
http://security.debian.org/pool/updates/main/s/squid/squid-cgi_2.4.6-2woody7_hppa.deb
http://security.debian.org/pool/updates/main/s/squid/squidclient_2.4.6-2woody7_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/s/squid/squid_2.4.6-2woody7_m68k.deb
http://security.debian.org/pool/updates/main/s/squid/squid-cgi_2.4.6-2woody7_m68k.deb
http://security.debian.org/pool/updates/main/s/squid/squidclient_2.4.6-2woody7_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/s/squid/squid_2.4.6-2woody7_mips.deb
http://security.debian.org/pool/updates/main/s/squid/squid-cgi_2.4.6-2woody7_mips.deb
http://security.debian.org/pool/updates/main/s/squid/squidclient_2.4.6-2woody7_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/s/squid/squid_2.4.6-2woody7_mipsel.deb
http://security.debian.org/pool/updates/main/s/squid/squid-cgi_2.4.6-2woody7_mipsel.deb
http://security.debian.org/pool/updates/main/s/squid/squidclient_2.4.6-2woody7_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/s/squid/squid_2.4.6-2woody7_powerpc.deb
http://security.debian.org/pool/updates/main/s/squid/squid-cgi_2.4.6-2woody7_powerpc.deb
http://security.debian.org/pool/updates/main/s/squid/squidclient_2.4.6-2woody7_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/s/squid/squid_2.4.6-2woody7_s390.deb
http://security.debian.org/pool/updates/main/s/squid/squid-cgi_2.4.6-2woody7_s390.deb
http://security.debian.org/pool/updates/main/s/squid/squidclient_2.4.6-2woody7_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/s/squid/squid_2.4.6-2woody7_sparc.deb
http://security.debian.org/pool/updates/main/s/squid/squid-cgi_2.4.6-2woody7_sparc.deb
http://security.debian.org/pool/updates/main/s/squid/squidclient_2.4.6-2woody7_sparc.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。