Debians sikkerhedsbulletin

DSA-693-1 luxman -- bufferoverløb

Rapporteret den:
14. mar 2005
Berørte pakker:
luxman
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Bugtraq-databasen (hos SecurityFocus): BugTraq-id 12797.
I Mitres CVE-ordbog: CVE-2005-0385.
Yderligere oplysninger:

Kevin Finisterre har opdaget et bufferoverløb i luxman, en SVGA-baseret PacMan-klon. Sårbarheden kunne gøre det muligt at udføre vilkårlige kommandoer som root.

I den stabile distribution (woody) er dette problem rettet i version 0.41-17.2.

I den ustabile distribution (sid) er dette problem rettet i version 0.41-20.

Vi anbefaler at du opgraderer din luxman-pakke.

Rettet i:

Debian GNU/Linux 3.0 (woody)

Kildekode:
http://security.debian.org/pool/updates/main/l/luxman/luxman_0.41-17.2.dsc
http://security.debian.org/pool/updates/main/l/luxman/luxman_0.41-17.2.diff.gz
http://security.debian.org/pool/updates/main/l/luxman/luxman_0.41.orig.tar.gz
Intel IA-32:
http://security.debian.org/pool/updates/main/l/luxman/luxman_0.41-17.2_i386.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.