Debian-Sicherheitsankündigung

DSA-693-1 luxman -- Pufferüberlauf

Datum des Berichts:
14. Mär 2005
Betroffene Pakete:
luxman
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In der Bugtraq-Datenbank (bei SecurityFocus): BugTraq ID 12797.
In Mitres CVE-Verzeichnis: CVE-2005-0385.
Weitere Informationen:

Kevin Finisterre entdeckte einen Pufferüberlauf in luxman, einem SVGA-basierten PacMan-Clone, der die Ausführung von beliebigen Befehlen als root zur Folge haben kann.

Für die Stable-Distribution (Woody) wurde dieses Problem in Version 0.41-17.2 behoben.

Für die Unstable-Distribution (Sid) wurde dieses Problem in Version 0.41-20 behoben.

Wir empfehlen Ihnen, Ihr luxman-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 3.0 (woody)

Quellcode:
http://security.debian.org/pool/updates/main/l/luxman/luxman_0.41-17.2.dsc
http://security.debian.org/pool/updates/main/l/luxman/luxman_0.41-17.2.diff.gz
http://security.debian.org/pool/updates/main/l/luxman/luxman_0.41.orig.tar.gz
Intel IA-32:
http://security.debian.org/pool/updates/main/l/luxman/luxman_0.41-17.2_i386.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.