Debian セキュリティ勧告

DSA-693-1 luxman -- バッファオーバフロー

報告日時:
2005-03-14
影響を受けるパッケージ:
luxman
危険性:
あり
参考セキュリティデータベース:
(SecurityFocus の) Bugtraq データベース: BugTraq ID 12797.
Mitre の CVE 辞書: CVE-2005-0385.
詳細:

Kevin Finisterre さんは、SVGAlib を使ったパックマンクローン、 luxman にバッファオーバフローを発見しました。 これによって、root 権限での任意のコマンドの実行が可能になります。

安定版ディストリビューション (stable、コードネーム woody) では、この問題はバージョン 0.41-17.2 で修正されています。

不安定版ディストリビューション (unstable、コードネーム sid) では、この問題はバージョン 0.41-20 で修正されています。

luxman パッケージのアップグレードをお勧めします。

修正:

Debian GNU/Linux 3.0 (woody)

ソース:
http://security.debian.org/pool/updates/main/l/luxman/luxman_0.41-17.2.dsc
http://security.debian.org/pool/updates/main/l/luxman/luxman_0.41-17.2.diff.gz
http://security.debian.org/pool/updates/main/l/luxman/luxman_0.41.orig.tar.gz
Intel IA-32:
http://security.debian.org/pool/updates/main/l/luxman/luxman_0.41-17.2_i386.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。