Bulletin d'alerte Debian

DSA-694-1 xloadimage -- Entrée non vérifiée, dépassement d'entier

Date du rapport :
21 mars 2005
Paquets concernés :
xloadimage
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 298926.
Dans le dictionnaire CVE du Mitre : CVE-2005-0638, CVE-2005-0639.
Plus de précisions :

Plusieurs vulnérabilités ont été découvertes dans xloadimage, un visualiseur d'images pour X11. Le projet « Common Vulnerabilities and Exposures » a identifié les problèmes suivants :

  • CAN-2005-0638

    Tavis Ormandy de l'équipe d'audit de sécurité de Gentoo Linux a rapporté un défaut dans le traitement des images compressées, au cours duquel les métacaractères d'invite de commande ne sont pas correctement échappés.

  • CAN-2005-0639

    Il a été découvert que les propriétés des images n'étaient pas correctement vérifiées, ce qui pouvait mener à des erreurs de gestion du tampon.

Pour l'actuelle distribution stable (Woody), ces problèmes ont été corrigés dans la version 4.1-10woody1.

Pour la distribution instable (Sid), ces problèmes ont été corrigés dans la version 4.1-14.2.

Nous vous recommandons de mettre à jour votre paquet xloadimage.

Corrigé dans :

Debian GNU/Linux 3.0 (woody)

Source :
http://security.debian.org/pool/updates/main/x/xloadimage/xloadimage_4.1-10woody1.dsc
http://security.debian.org/pool/updates/main/x/xloadimage/xloadimage_4.1-10woody1.diff.gz
http://security.debian.org/pool/updates/main/x/xloadimage/xloadimage_4.1.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/x/xloadimage/xloadimage_4.1-10woody1_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/x/xloadimage/xloadimage_4.1-10woody1_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/x/xloadimage/xloadimage_4.1-10woody1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/x/xloadimage/xloadimage_4.1-10woody1_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/x/xloadimage/xloadimage_4.1-10woody1_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/x/xloadimage/xloadimage_4.1-10woody1_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/x/xloadimage/xloadimage_4.1-10woody1_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/x/xloadimage/xloadimage_4.1-10woody1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/x/xloadimage/xloadimage_4.1-10woody1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/x/xloadimage/xloadimage_4.1-10woody1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/x/xloadimage/xloadimage_4.1-10woody1_sparc.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.