Debian Security Advisory

DSA-705-1 wu-ftpd -- missing input sanitising

Date Reported:
04 Apr 2005
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2005-0256, CVE-2003-0854.
More information:

Several denial of service conditions have been discovered in wu-ftpd, the popular FTP daemon. The Common Vulnerabilities and Exposures project identifies the following problems:

  • CAN-2005-0256

    Adam Zabrocki discovered a denial of service condition in wu-ftpd that could be exploited by a remote user and cause the server to slow down by resource exhaustion.

  • CAN-2003-0854

    Georgi Guninski discovered that /bin/ls may be called from within wu-ftpd in a way that will result in large memory consumption and hence slow down the server.

For the stable distribution (woody) these problems have been fixed in version 2.6.2-3woody5.

For the unstable distribution (sid) these problems have been fixed in version 2.6.2-19.

We recommend that you upgrade your wu-ftpd package.

Fixed in:

Debian GNU/Linux 3.0 (woody)

Architecture-independent component:
Intel IA-32:
Intel IA-64:
Motorola 680x0:
Big endian MIPS:
Little endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.