Debian-Sicherheitsankündigung

DSA-709-1 libexif -- Pufferüberlauf

Datum des Berichts:
15. Apr 2005
Betroffene Pakete:
libexif
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In der Debian-Fehlerdatenbank: Fehler 298464.
In Mitres CVE-Verzeichnis: CVE-2005-0664.
Weitere Informationen:

Sylvain Defresne entdeckte einen Pufferüberlauf in libexif, einer Bibliothek zum Parsen von EXIF-Dateien (z.B. JPEG-Dateien mit zusätzlichen Markern). Dieser Fehler kann ausgenutzt werden, um die Applikation zum Absturz zu bringen und möglicherweise auch beliebigen Code auszuführen.

Für die Stable-Distribution (Woody) wurde dieses Problem in Version 0.5.0-1woody1 behoben.

Für die Unstable-Distribution (Sid) wurde dieses Problem in Version 0.6.9-5 behoben.

Wir empfehlen Ihnen, Ihr libexif-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 3.0 (woody)

Quellcode:
http://security.debian.org/pool/updates/main/libe/libexif/libexif_0.5.0-1woody1.dsc
http://security.debian.org/pool/updates/main/libe/libexif/libexif_0.5.0-1woody1.diff.gz
http://security.debian.org/pool/updates/main/libe/libexif/libexif_0.5.0.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/libe/libexif/libexif-dev_0.5.0-1woody1_alpha.deb
http://security.debian.org/pool/updates/main/libe/libexif/libexif5_0.5.0-1woody1_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/libe/libexif/libexif-dev_0.5.0-1woody1_arm.deb
http://security.debian.org/pool/updates/main/libe/libexif/libexif5_0.5.0-1woody1_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/libe/libexif/libexif-dev_0.5.0-1woody1_i386.deb
http://security.debian.org/pool/updates/main/libe/libexif/libexif5_0.5.0-1woody1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/libe/libexif/libexif-dev_0.5.0-1woody1_ia64.deb
http://security.debian.org/pool/updates/main/libe/libexif/libexif5_0.5.0-1woody1_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/libe/libexif/libexif-dev_0.5.0-1woody1_hppa.deb
http://security.debian.org/pool/updates/main/libe/libexif/libexif5_0.5.0-1woody1_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/libe/libexif/libexif-dev_0.5.0-1woody1_m68k.deb
http://security.debian.org/pool/updates/main/libe/libexif/libexif5_0.5.0-1woody1_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/libe/libexif/libexif-dev_0.5.0-1woody1_mips.deb
http://security.debian.org/pool/updates/main/libe/libexif/libexif5_0.5.0-1woody1_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/libe/libexif/libexif-dev_0.5.0-1woody1_mipsel.deb
http://security.debian.org/pool/updates/main/libe/libexif/libexif5_0.5.0-1woody1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/libe/libexif/libexif-dev_0.5.0-1woody1_powerpc.deb
http://security.debian.org/pool/updates/main/libe/libexif/libexif5_0.5.0-1woody1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/libe/libexif/libexif-dev_0.5.0-1woody1_s390.deb
http://security.debian.org/pool/updates/main/libe/libexif/libexif5_0.5.0-1woody1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/libe/libexif/libexif-dev_0.5.0-1woody1_sparc.deb
http://security.debian.org/pool/updates/main/libe/libexif/libexif5_0.5.0-1woody1_sparc.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.