Bulletin d'alerte Debian

DSA-711-1 info2www -- Mauvaise vérification des entrées

Date du rapport :
19 avril 2005
Paquets concernés :
info2www
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 281655.
Dans le dictionnaire CVE du Mitre : CVE-2004-1341.
Plus de précisions :

Nicolas Gregoire a découvert une vulnérabilité de script sur les éléments dynamiques (cross-site scripting) dans info2www, un convertisseur de fichiers du format info vers le format HTML. Une personne malintentionnée pouvait placer un lien anodin sur le web, dont l'activation dans le navigateur web de la victime permettait l'exécution de commandes arbitraires.

Pour l'actuelle distribution stable (Woody), ce problème a été corrigé dans la version 1.2.2.9-20woody1.

Pour la distribution instable (Sid), ce problème a été corrigé dans la version 1.2.2.9-23.

Nous vous recommandons de mettre à jour votre paquet info2www.

Corrigé dans :

Debian GNU/Linux 3.0 (woody)

Source :
http://security.debian.org/pool/updates/main/i/info2www/info2www_1.2.2.9-20woody1.dsc
http://security.debian.org/pool/updates/main/i/info2www/info2www_1.2.2.9-20woody1.diff.gz
http://security.debian.org/pool/updates/main/i/info2www/info2www_1.2.2.9.orig.tar.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/i/info2www/info2www_1.2.2.9-20woody1_all.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.