Debian Security Advisory

DSA-713-1 junkbuster -- several vulnerabilities

Date Reported:
21 Apr 2005
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2005-1108, CVE-2005-1109.
More information:

Several bugs have been found in junkbuster, a HTTP proxy and filter. The Common Vulnerabilities and Exposures project identifies the following vulnerabilities:

  • CAN-2005-1108

    James Ranson discovered that an attacker can modify the referrer setting with a carefully crafted URL by accidentally overwriting a global variable.

  • CAN-2005-1109

    Tavis Ormandy from the Gentoo Security Team discovered several heap corruptions due to inconsistent use of an internal function that can crash the daemon or possibly lead to the execution of arbitrary code.

For the stable distribution (woody) these problems have been fixed in version 2.0.2-0.2woody1.

The unstable distribution (sid) doesn't contain the junkbuster package anymore.

We recommend that you upgrade your junkbuster package.

Fixed in:

Debian GNU/Linux 3.0 (woody)

Intel IA-32:
Intel IA-64:
Motorola 680x0:
Big endian MIPS:
Little endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.