Debian Security Advisory

DSA-718-2 ethereal -- buffer overflow

Date Reported:
28 Apr 2005
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2005-0739.
More information:

[ This version lists the correct packages in the packages section. ]

A buffer overflow has been detected in the IAPP dissector of Ethereal, a commonly used network traffic analyser. A remote attacker may be able to overflow a buffer using a specially crafted packet. More problems have been discovered which don't apply to the version in woody but are fixed in sid as well.

For the stable distribution (woody) this problem has been fixed in version 0.9.4-1woody12.

For the unstable distribution (sid) these problems have been fixed in version 0.10.10-1.

We recommend that you upgrade your ethereal packages.

Fixed in:

Debian GNU/Linux 3.0 (woody)

Intel IA-32:
Intel IA-64:
Motorola 680x0:
Big endian MIPS:
Little endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.

MD5 checksums of the listed files are available in the revised advisory.