Debian-Sicherheitsankündigung

DSA-721-1 squid -- Design-Fehler

Datum des Berichts:
06. Mai 2005
Betroffene Pakete:
squid
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In der Debian-Fehlerdatenbank: Fehler 307132.
In Mitres CVE-Verzeichnis: CVE-2005-1345.
Weitere Informationen:

Michael Bhola entdeckte einen Fehler in Squid, dem beliebten WWW-Proxy-Cache. Wenn Squid fehlende oder ungültige ACLs (Zugriffskontrolllisten) in der http_access-Konfiguration feststellt, wird kein unbehebbarer Fehler ausgelöst. Dadurch können ACLs in Kraft treten, die weniger restriktiv sind als vom Administrator vorgesehen.

Für die Stable-Distribution (Woody) wurde dieses Problem in Version 2.4.6-2woody8 behoben.

Für die Unstable-Distribution (Sid) wurde dieses Problem in Version 2.5.9-7 behoben.

Wir empfehlen Ihnen, Ihre squid-Pakete zu aktualisieren.

Behoben in:

Debian GNU/Linux 3.0 (woody)

Quellcode:
http://security.debian.org/pool/updates/main/s/squid/squid_2.4.6-2woody8.dsc
http://security.debian.org/pool/updates/main/s/squid/squid_2.4.6-2woody8.diff.gz
http://security.debian.org/pool/updates/main/s/squid/squid_2.4.6.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/s/squid/squid_2.4.6-2woody8_alpha.deb
http://security.debian.org/pool/updates/main/s/squid/squid-cgi_2.4.6-2woody8_alpha.deb
http://security.debian.org/pool/updates/main/s/squid/squidclient_2.4.6-2woody8_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/s/squid/squid_2.4.6-2woody8_arm.deb
http://security.debian.org/pool/updates/main/s/squid/squid-cgi_2.4.6-2woody8_arm.deb
http://security.debian.org/pool/updates/main/s/squid/squidclient_2.4.6-2woody8_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/s/squid/squid_2.4.6-2woody8_i386.deb
http://security.debian.org/pool/updates/main/s/squid/squid-cgi_2.4.6-2woody8_i386.deb
http://security.debian.org/pool/updates/main/s/squid/squidclient_2.4.6-2woody8_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/s/squid/squid_2.4.6-2woody8_ia64.deb
http://security.debian.org/pool/updates/main/s/squid/squid-cgi_2.4.6-2woody8_ia64.deb
http://security.debian.org/pool/updates/main/s/squid/squidclient_2.4.6-2woody8_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/s/squid/squid_2.4.6-2woody8_hppa.deb
http://security.debian.org/pool/updates/main/s/squid/squid-cgi_2.4.6-2woody8_hppa.deb
http://security.debian.org/pool/updates/main/s/squid/squidclient_2.4.6-2woody8_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/s/squid/squid_2.4.6-2woody8_m68k.deb
http://security.debian.org/pool/updates/main/s/squid/squid-cgi_2.4.6-2woody8_m68k.deb
http://security.debian.org/pool/updates/main/s/squid/squidclient_2.4.6-2woody8_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/s/squid/squid_2.4.6-2woody8_mips.deb
http://security.debian.org/pool/updates/main/s/squid/squid-cgi_2.4.6-2woody8_mips.deb
http://security.debian.org/pool/updates/main/s/squid/squidclient_2.4.6-2woody8_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/s/squid/squid_2.4.6-2woody8_mipsel.deb
http://security.debian.org/pool/updates/main/s/squid/squid-cgi_2.4.6-2woody8_mipsel.deb
http://security.debian.org/pool/updates/main/s/squid/squidclient_2.4.6-2woody8_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/s/squid/squid_2.4.6-2woody8_powerpc.deb
http://security.debian.org/pool/updates/main/s/squid/squid-cgi_2.4.6-2woody8_powerpc.deb
http://security.debian.org/pool/updates/main/s/squid/squidclient_2.4.6-2woody8_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/s/squid/squid_2.4.6-2woody8_s390.deb
http://security.debian.org/pool/updates/main/s/squid/squid-cgi_2.4.6-2woody8_s390.deb
http://security.debian.org/pool/updates/main/s/squid/squidclient_2.4.6-2woody8_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/s/squid/squid_2.4.6-2woody8_sparc.deb
http://security.debian.org/pool/updates/main/s/squid/squid-cgi_2.4.6-2woody8_sparc.deb
http://security.debian.org/pool/updates/main/s/squid/squidclient_2.4.6-2woody8_sparc.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.