Debian-Sicherheitsankündigung

DSA-722-1 smail -- Pufferüberlauf

Datum des Berichts:
09. Mai 2005
Betroffene Pakete:
smail
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In der Debian-Fehlerdatenbank: Fehler 301428.
In Mitres CVE-Verzeichnis: CVE-2005-0892.
Weitere Informationen:

In Smail, einem elektronischen E-Mail-Transportsystem, wurde ein Pufferüberlauf entdeckt, der es entfernten Angreifern und lokalen Benutzern ermöglicht, beliebigen Code auszuführen

Für die Stable-Distribution (Woody) wurde dieses Problem in Version 3.2.0.114-4woody1 behoben.

Für die Unstable-Distribution (Sid) wurde dieses Problem in Version 3.2.0.115-7 behoben.

Wir empfehlen Ihnen, Ihr smail-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 3.0 (woody)

Quellcode:
http://security.debian.org/pool/updates/main/s/smail/smail_3.2.0.114-4woody1.dsc
http://security.debian.org/pool/updates/main/s/smail/smail_3.2.0.114-4woody1.diff.gz
http://security.debian.org/pool/updates/main/s/smail/smail_3.2.0.114.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/s/smail/smail_3.2.0.114-4woody1_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/s/smail/smail_3.2.0.114-4woody1_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/s/smail/smail_3.2.0.114-4woody1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/s/smail/smail_3.2.0.114-4woody1_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/s/smail/smail_3.2.0.114-4woody1_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/s/smail/smail_3.2.0.114-4woody1_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/s/smail/smail_3.2.0.114-4woody1_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/s/smail/smail_3.2.0.114-4woody1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/s/smail/smail_3.2.0.114-4woody1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/s/smail/smail_3.2.0.114-4woody1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/s/smail/smail_3.2.0.114-4woody1_sparc.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.