Debians sikkerhedsbulletin

DSA-726-1 oops -- formatstrengssårbarhed

Rapporteret den:
20. maj 2005
Berørte pakker:
oops
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 307360.
I Mitres CVE-ordbog: CVE-2005-1121.
Yderligere oplysninger:

En formatstrengssårbarhed er opdaget i Oops' modul til autenficiering i MySQL/PgSQL. Oops er en HTTP-mellemlagerserver skrevet med ydeevne for øje.

I den stabile distribution (woody) er dette problem rettet i version 1.5.19.cvs.20010818-0.1woody1

I den ustabile distribution (sid) vil dette problem snart blive rettet.

Vi anbefaler at du opgraderer din oops-pakke.

Rettet i:

Debian GNU/Linux 3.0 (woody)

Kildekode:
http://security.debian.org/pool/updates/main/o/oops/oops_1.5.19.cvs.20010818-0.1woody1.dsc
http://security.debian.org/pool/updates/main/o/oops/oops_1.5.19.cvs.20010818-0.1woody1.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/o/oops/oops_1.5.19.cvs.20010818-0.1woody1_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/o/oops/oops_1.5.19.cvs.20010818-0.1woody1_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/o/oops/oops_1.5.19.cvs.20010818-0.1woody1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/o/oops/oops_1.5.19.cvs.20010818-0.1woody1_ia64.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/o/oops/oops_1.5.19.cvs.20010818-0.1woody1_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/o/oops/oops_1.5.19.cvs.20010818-0.1woody1_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/o/oops/oops_1.5.19.cvs.20010818-0.1woody1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/o/oops/oops_1.5.19.cvs.20010818-0.1woody1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/o/oops/oops_1.5.19.cvs.20010818-0.1woody1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/o/oops/oops_1.5.19.cvs.20010818-0.1woody1_sparc.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.