Debian Security Advisory

DSA-737-1 clamav -- remote denial of service

Date Reported:
05 Jul 2005
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2005-1922, CVE-2005-1923, CVE-2005-2056, CVE-2005-2070.
More information:

A number of potential remote denial of service vulnerabilities have been identified in ClamAV. In addition to the four issues identified by CVE ID above, there are fixes for issues in libclamav/cvd.c and libclamav/message.c. Together, these issues could allow a carefully crafted message to crash a ClamAV scanner or exhaust various resources on the machine running the scanner.

For the stable distribution (sarge), these problems have been fixed in version 0.84-2.sarge.1.

We recommend that you upgrade your clamav package.

Fixed in:

Debian GNU/Linux 3.1 (sarge)

Architecture-independent component:
HP Precision:
Intel IA-32:
Intel IA-64:
Motorola 680x0:
Big-endian MIPS:
Little-endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.