Debian Security Advisory

DSA-747-1 egroupware -- input validation error

Date Reported:
10 Jul 2005
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2005-1921.
More information:

A vulnerability has been identified in the xmlrpc library included in the egroupware package. This vulnerability could lead to the execution of arbitrary commands on the server running egroupware.

The old stable distribution (woody) did not include egroupware.

For the current stable distribution (sarge), this problem is fixed in version

For the unstable distribution (sid), this problem is fixed in version

We recommend that you upgrade your egroupware package.

Fixed in:

Debian GNU/Linux 3.1 (sarge)

Architecture-independent component:

MD5 checksums of the listed files are available in the original advisory.