Debians sikkerhedsbulletin

DSA-759-1 phppgadmin -- manglende kontrol af inddata

Rapporteret den:
18. jul 2005
Berørte pakker:
phppgadmin
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Bugtraq-databasen (hos SecurityFocus): BugTraq-id 14142.
I Mitres CVE-ordbog: CVE-2005-2256.
Yderligere oplysninger:

En sårbarhed er opdaget i phppgadmin, et sæt PHP-skripter til administrering af PostgreSQL via en webbrowser. Sårbarheden kunne medføre afsløring af følsomme oplysninger. En vellykket udnyttelse kræver at "magic_quotes_gpc" er slået fra.

Den gamle stabile distribution (woody) er ikke påvirket af dette problem.

I den stabile distribution (sarge) er dette problem rettet i version 3.5.2-5.

I den ustabile distribution (sid) er dette problem rettet i version 3.5.4.

Vi anbefaler at du opgraderer din phppgadmin-pakke.

Rettet i:

Debian GNU/Linux 3.1 (sarge)

Kildekode:
http://security.debian.org/pool/updates/main/p/phppgadmin/phppgadmin_3.5.2-5.dsc
http://security.debian.org/pool/updates/main/p/phppgadmin/phppgadmin_3.5.2-5.diff.gz
http://security.debian.org/pool/updates/main/p/phppgadmin/phppgadmin_3.5.2.orig.tar.gz
Arkitekturuafhængig komponent:
http://security.debian.org/pool/updates/main/p/phppgadmin/phppgadmin_3.5.2-5_all.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.