Debian-Sicherheitsankündigung

DSA-759-1 phppgadmin -- Fehlende Entschärfung der Eingabe

Datum des Berichts:
18. Jul 2005
Betroffene Pakete:
phppgadmin
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In der Bugtraq-Datenbank (bei SecurityFocus): BugTraq ID 14142.
In Mitres CVE-Verzeichnis: CVE-2005-2256.
Weitere Informationen:

Eine Verwundbarkeit wurde in phppgadmin entdeckt, einem Satz von PHP-Skripten zur Administration von PostgreSQL über das WWW. Diese kann wichtige Informationen preisgeben. Für das erfolgreiche Ausnutzen der Verwundbarkeit ist es notwendig, dass »magic_quotes_gpc« ausgeschaltet ist.

Die alte Stable-Distribution (Woody) ist von diesem Problem nicht betroffen.

Für die Stable-Distribution (Sarge) wurde dieses Problem in Version 3.5.2-5 behoben.

Für die Unstable-Distribution (Sid) wurde dieses Problem in Version 3.5.4 behoben.

Wir empfehlen Ihnen, Ihr phppgadmin-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 3.1 (sarge)

Quellcode:
http://security.debian.org/pool/updates/main/p/phppgadmin/phppgadmin_3.5.2-5.dsc
http://security.debian.org/pool/updates/main/p/phppgadmin/phppgadmin_3.5.2-5.diff.gz
http://security.debian.org/pool/updates/main/p/phppgadmin/phppgadmin_3.5.2.orig.tar.gz
Architektur-unabhängige Dateien:
http://security.debian.org/pool/updates/main/p/phppgadmin/phppgadmin_3.5.2-5_all.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.